Adapting FancyLibs from Debian 11 Bullseye to 12 Bookworm, later eventually MinGW-9 to MinGW-10

Introduction

About every 2 years Debian introduces a new release.

At the time I'm writing this Debian Bookworm has had it's hard freeze, and due to the switch of OpenSSL 3 we started early this time.

The following notes shall provide the order in which FancyLibs shall be adapted and released for a new Debian release and are based on Adapting FancyLibs & MinGW-Pkg from Debian 9 Stretch to 10 Buster, Mingw-7 to Mingw-8 and Adapting FancyLibs & MinGW-Pkg from Debian 10 Buster to 11 Bullseye, MinGW-8 to MinGW-9

Adapting FancyLibs to new Debian Release

The steps per sub project are the same as described for "HelloWorld projects* in Adapting PBA to new Debian Release, with -o unix (before MinGW adaption) or -o "arch|unix|9" after MinGW adaption.

FancyLibs subproject rebuild order phase 1

We have dropped armhf support.

FancyLibs as well as most to all C++ libraries are developed as PBA-Category and Generation fancylibs-3.8, so existing setups can be maintained with fancylibs 3.7 from PBA-C. and G. fancylibs-3.

Furthermore, new builds for Debian 10 stretch and 11 buster as well as MinGW-8 are beeing dropped.

Project (subdir)

Archs (-o parameter)

Remarks general

Status & Remarks buster/bullseye

Release with Bookworm
(resp. Bullseye)

Project (subdir)

Archs (-o parameter)

Remarks general

Status & Remarks buster/bullseye

Release with Bookworm
(resp. Bullseye)

fancylog

arch



OK

1.0.3-13

cute-headers

arch

Data only

OK

1.6.1-16

fancylibs

arch



OK

3.8.0-0beta1

fancydb

-

Unix only.

OK. Suspended MySQL which's missing in Bookworm.

0.7.0-5

fancydrawing

arch



OK

0.6.3-6

fancygpsdclient

unix



OK

0.4.3-12

fancyhttpd

arch



OK

0.8.1-8

fancylogd

unix



OK

0.1.0-9

fancypkcs11

unix



OK

0.4.1-6

fancypcsc

unix



OK

0.2.5-10

fancymodbus

-

Unix only.

OK

0.2.4-6

fancysax

arch



OK

0.6.1-15

fancyqt5

arch



OK

0.1.1-4

fancysane

-



OK

0.3.4-3

fancyqmi

-

Unix only.

NOK, linking problem, might be in libqmi

0.3.4-4 (0.3.4-2)

fancyssl-tools

unix



OK

0.4.0-10

fancylaunch

arch



OK

1.1.1-4

Postponed: MinGW-Pkg rebuilds

Disclaimer: The MinGW-Pkg generation does NOT refer to the version of the Mingw-W64 upstream project, but is raised with every Debian generation and includes newer version of the cross-built 3rd-party libraries.

Order based on mingw 6 rebuild order

Project (mingw-pkg subdir pattern)

Dep.

Version MinGW-9 mingw-pkg (upstream)

Version MinGW-10 mingw-pkg (upstream)

Bookworm Status

Project (mingw-pkg subdir pattern)

Dep.

Version MinGW-9 mingw-pkg (upstream)

Version MinGW-10 mingw-pkg (upstream)

Bookworm Status

(osslsigncode)

-

-

-

provided by Debian now

(mingw-w64-binutils)



- (2.35.2-2+8.11+b3)

-

provided by Debian now as binutils-mingw-w64-x86-64

mingw-w64-gcc-rt



10.2.1 (10.2.1-6+24.2),
uses Debian's g++-mingw64-*

obsolete

now provided as
gcc-mingw-w64-x86-64-win32-runtime
by debian

mingw-w64-zlib

mingw-w64-gcc-rt

1.2.11-4 (1.2.11)

obsolete

now provided as
libz-mingw-w64-dev and libz-mingw-w64
by debian

mingw-w64-openssl

mingw-w64-zlib

1.1.1l-1 (1.1.1l)

3.2.1

-

mingw-w64-libpng

mingw-w64-zlib

1.6.37-2 (1.6.37, 1.7 still in beta)

obsolete, will be built inline with Qt5/6

-

mingw-w64-libjpeg

mingw-w64-libpng

9d-1 (9d)

obsolete, will be built inline with Qt5/6

-

mingw-w64-libtiff

mingw-w64-libjpeg

4.3.0-0 (4.3.0)

obsolete, will be built inline with Qt5/6

-

mingw-w64-libmng

mingw-w64-libjpeg

2.0.3-5 (2.0.3)

obsolete, will be built inline with Qt5/6

-

mingw-w64-bzip2

mingw-w64-gcc-rt

1.0.6-5 (1.0.6)

obsolete

TBD

mingw-w64-libboost

mingw-w64-bzip2

-

-

- (ignored)

mingw-w64-libiconv

mingw-w64-gcc-rt

1.16-2 (1.16)

1.17-0beta1

OK

mingw-w64-libxml2

mingw-w64-libiconv

2.9.10-0 (2.9.10, no sources for 2.9.12)

2.12.6-0beta1

OK

mingw-w64-gettext

mingw-w64-libxml2

0.21-0 (0.21)

0.20.2-0 (0.20.2)

0.22.5-0beta1

OK

mingw-w64-qt5



5.15.2-0clazzespba1 (5.15.2)

TBD, replace by Qt6, if possible.

TBD

mingw-w64-jni-headers



17.0.1-1 (17.0.1+12-1+deb11u2)

TBD

TBD

Postponed: FancyLibs subproject rebuild order phase 3

The recommended order for phase 3 (after MinGW adaptions) is:

Project (subdir)

Archs (-o parameter)

Version with MinGW-9
for Bullseye

Version with MinGW-10
for Bookworm

Remarks, Bookworm
Status

Project (subdir)

Archs (-o parameter)

Version with MinGW-9
for Bullseye

Version with MinGW-10
for Bookworm

Remarks, Bookworm
Status

fancylog

- (arch|10)

1.0.3-10

TBD

TBD

cute-headers

- (arch|10)

1.6.1-13 (8_1.6.1)

TBD

TBD

fancylibs

- (arch|10)

3.7.4-12

TBD

TBD

fancydrawing

- (arch|10)

0.6.3-3

TBD

TBD

fancygpsdclient

- (unix|10)

0.4.3-9

TBD

TBD

fancyhttpd

- (arch|10)

0.8.1-2

TBD

TBD

fancylogd

- (unix|10)

0.1.0-7

TBD

TBD

fancypcsc

- (arch|10)

0.2.5-7

TBD

TBD

fancysax

- (arch|10)

0.6.1-12

TBD

TBD

fancyqt5

arch

0.1.1-2

TBD

TBD

fancyssl-tools

- (arch|10)

TBD
Was: 0.4.0-6

TBD

TBD

fancylaunch

- (arch|10)

1.1.1-2

TBD

TBD

Obsolete subdirs

Project (subdir)

Remarks

Project (subdir)

Remarks

base64

never even built for stretch

fancylogview,
fancyqt4*,
mingw-w*-qt4*

No more QT4 in Bullseye

fancyxmlsock

Looks lke old experimental code now in fancysock

gpsfake-runner

shell scripts only

jnix

never even built for stretch

mingw-w64-libboost

not in use

osslsigncode

not in use